NSHT Blockchain relaunch
Incident Report for Nutshell Exchange
Resolved
Issue transferred to maintenance to suppress alerts.
Posted May 19, 2020 - 11:19 UTC
Monitoring
We are deploying blockchain and will release update as soon we done it.
Posted May 18, 2020 - 18:55 UTC
Update
We are continuing to investigate this issue.
Posted May 18, 2020 - 18:51 UTC
Investigating
We are currently re-establishing NSHT Blockchain and it services.
Posted May 18, 2020 - 18:51 UTC